Getting Started with Maplinfo Professional
Hands On Session 1D

In this session, the following topics will be coved:
Open a DBF file
Create Points
Geocode to 5 digit ZIPCodes
Use Query > Select
Use the Select Tools
Create a Thematic Map

The Layout Window
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Open a DBF file

A DBF file is common file type that is created byaxiety of software packages such as
Microsoft Excel, Microsoft Access, and Mapinfo Rs$ional.

Navigate to File to Open.
Navigate to the file folder and drive where the i# located.
Change the Files of Type drop down to dBASE DBF.
Choose the file 1D US Sites.dbf and press Open.
open 2| x|
Look in: [ 3 Data x| « @ ek E-

| 1D_US_CUST.DBF
5l 1D US_Sites.dbf
| Copy of 1D_US_CUST.DEF
| Copy of 1D_US_Sites, DEF

File name: [1D_Us_Sites.dbf | Qpen

Files of type: |dBASE DBF (".dbf) -l Cancel

Prefemed Yiew: I.-'l'-.utumatic j Help
{* Maplnfo Places ™| Create copy it b aplnfa Farmat for read/write

" Standard Places

A
Other file types supported by Maplinfo Professiarshg the File > Open dialog are:

Mapinfo Table

MapInfo Workspace

Microsoft Access MDB

Microsoft Excel and Lotus Spreadsheets
Tex Files: TXT and CSV

Raster and Grid Files

ESRI SHP
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BASE DBF Information x|

Eile Character Set:

] I Cancel | Help |

- Press OK at the dBASE DBF Information dialog.

The file displays in a browse window, signally file has no geography or map
component.

#7 MapInfo Professional

Fle Edit Tools Objects Query Tgble Options Prowse MWindow Autoloager ImagsConmect Help

o] = = O e Y il o o o S R 1 NES

e

Name Type Sales_03 Sales_04 Profit_los Long 4|
Boston Cettics ENTERTAINMENT 1,829.000000000 3,136.000000000 10,344.000000000
Reading Rairoad TRANSPORTATIC 13,635.000000000 13,475.000000000 92,003.000000000
‘Worcester Sauce Company | RETAIL 16,298.000000000 26,126.000000000 -2,071.000000000
Hauppauge Sausage Factor | RETAIL 7,167.000000000 11,519.000000000 -3,081.000000000
Mahopac Falls Hospital RETAIL 10,576.000000000 18,973.000000000 | 107,654.000000000
New York Alarm Systems | RETAIL 11,626.000000000 18,654.000000000 | 108,787.000000000
Paterson Boxing Club ENTERTAINMENT 12,504.000000000 20,057.000000000 90,787.000000000
Binghamton University EDUCATION 1,713.000000000 1,693.000000000 -8,091.000000000
Norfolk Silverware RETAIL 10,733.000000000 17,226.000000000 88,787.000000000
Portsmouth Radic ENTERTAINMENT 11,618.000000000 18,643.000000000 | 111,565.000000000
Arlington Memorials: RETAIL 803.000000000 793.000000000 97 8928.000000000
Bethesda Modeling School | EDUCATION 1,389.000000000 2,276.000000000 90,433.000000000
Kodak Cameras RETAIL 9,091.000000000 14,600.000000000 96,787.000000000
Buffalo Sabers ENTERTAINMENT 2,814.000000000 4,558.000000000 23,455.000000000
Pittsburgh International Airpr | TRANSPORTATIC 12,583.000000000 20,158.000000000 91,011.000000000
Fort Lauderdale Baseballs | RETAIL 3,687.000000000 3,617.000000000 88,976.000000000
Miami Heat ENTERTAINMENT §,857.000000000 11,028.000000000 -1,047.000000000
Qrlande Costumes RETAIL 8,590.000000000 8,440.000000000 -1,022.000000000
Cape Coral Surfboards RETAIL 1,888.000000000 3,077.000000000 77,651.000000000
Columbus Shipping Compan | TRANSPORTATIC 4,227.000000000 6,820.000000000 78,700.000000000
Centennial Olympic Stadium | ENTERTAINMENT 872.000000000 1,454.000000000 93,001.000000000

L

EDDDDDDDDDDDDDDDDDDDDD

records 1-220f 105
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Create Points

Use the Create Point process to create point reptason if your file contains longitude
and latitudes values or x and y values.

Navigate to Table to Create Points.

From the Create Points for Table choose 1D US Sites

From the Get X Coordinates from Column choose Long.

From the Get Y Coordinates from Column choose Lat.

Press the Symbol Style button to define a defautt®l to be used for the table.

x
Create Paints for T able; |_1 015 Sites j

Cancel

d

uzing Symbol: | #

Get # Coordinates from Colurn: IL.:.ng j Prajectior... |

Get ' Coordinates from Colurnn: ILat

Le

Help

tulkiply the = Coordinates by |1

Fultiply the % Coordinates by |1

[ Display non-numernic figlds

[ Owenwiite existing points

Press OK.

NOTE: Use the Projection button to specify a proga other than Longitude and
Latitude.

To view the map created from the Create Point [m%ice

Navigate to Window to New Map Window.
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#* Mapinfo Professional =1

File Edit Tools Objects Query Table Options Map Window Autoloader ImageConnect Help

M EEEERR R R EED]

5i0]]
[Zoom: 1,760 mi - [Editing: Nane - [5electing: None [

To add more detail, open additional Mapinfo Prafesal tables to complete the map.
For example:

Navigate to File to Open and point to the file fsldprogram files\mapinfo\
\data\map_data\namerica\usa\usamaps” and choose USA

Press Open.
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Geocode to 5 Digit ZIPCodes

Geocode to 5 Digit ZIPCodes will create a pointdaecord at the center of the 5 Digit
ZIPCode specified in its row. If there is morertleme record geocoded to the same
ZIPCode, those points will be stacked on top oheatber.

Navigate to File to Open.

Navigate to the file folder and drive where the 8 located.
Change the Files of Type drop down to dBASE DBF.
Choose the file 1D US CUST.

Press Open.
Press OK from the dBASE DBF Information dialog box.
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Navigate to File to Open and point to the file fsidprogram files\mapinfo\
\data\map_data\namerica\usa\usamaps” and choosélR&

Press Open.

Navigate to Table to Geocode.
The Geocode dialog displays.
From the Geocode Table drop down choose 1D US CUST.
From the using Column drop down choose ZIP.
From the Search Table drop down choose US ZIPS.
From the for Objects in Column drop down choose ZIP

Press the Symbol Style button to define the defauttbol to be used for this
table.
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Press OK.
A note will display displaying the geocoding result

Press OK.

NOTE: Construct the following query to create aneption report noting those record
that have failed to geocode:

[72)
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To view the result of the geocode process:
Navigate to Window to New Map Window.
From the first Map Tables drop down choose 1D USSTU
From the second Map Tables drop down choose USA.
Press OK.
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Use Query > Select

Use Query > Select to create filters to extrachdatords that meet defined criteria. The
criterion is developed by the end-user.

To select based on character data.

This example uses the like operator can use wittic@) and place holders (). Use the
like operator when you may come across data thgthreapelled in many different ways
(Sears, Sears and Company, Sears, Roebuck and Co.).

Navigate to Query to Select.

From the Select Records from Table drop down ch@8s&)S CUST.
Press the Assist button.

From the Columns drop down choose Company

From the Operators drop down like.

Type “cher%”.

Press OK.

Press OK to execute the query.
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To select based on numeric data.

This example will parse out records that meet aeniothreshold. Use operators such as
H:”, H>H. H<”’ H< >”, and SO on.

Navigate to Query to Select.

From the Select Records from Table drop down ch@8s&)S CUST.
Press the Assist button.

From the Columns drop down choose Order_Amt.

From the Operators drop down >.

Type 15000.

To select based on multiple criteria.

This example will parse out records that meet aeniothreshold (order_amt greater
than $15,000) yet only belong to a specific comp@aynpany like “cher%”).

Navigate to Query to Select.

From the Select Records from Table drop down ch@8s&)S CUST.
Press the Assist button.

From the Columns drop down choose Order_Amt

From the Operators drop down >.

Type 15000.

From the Operators drop down choose AND.

From the Columns drop down choose Company.

From the Operators drop down choose like.

Type “cher%”.
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Press OK.
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Hands On Session 1D

Save Results from Query > Select and Query > SQicSe

File > Save Copy As File > Open (Table) Static

File > Save Workspace File > Open (Workspace Dyoam
File > Save Query File > Open (Table) Dynamic
Query > Select > Save Query > Select > Load Dynamic

Template

Template

MapWorld 2008
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Use the Select Tools

Use the Select tools from the Main Button Pad t&erfan screen” or “on map”
selections. This will allow to answer questionslsas “Who are my customer’s within a
50 mile radius?” and “Who are my customer’s ingkae of Texas?”.

The Select Tools:

Tool Action

Select Tool To make single, interactive selections.
Hold the <SHIFT> key to add to an
existing selection.

Radius Select To make selections based on a radius
created in the map window. Press the left
mouse button, hold, and drag. Hold the
<SHIFT> key to add to an existing
selection.

Boundary Select To select items that fall withineswsting
boundary. Hold the <SHIFT> key to add
to an existing selection.

Marquee Select To make selections based on a “marquee

box” created in the map window. Press the
left mouse button, hold, and drag. Hold th
<SHIFT> key to add to an existing
selection.

Polygon Select To make selections based on polygon

drawn inside the map window. Using the
left mouse button, click at point A, drag t(
point B, and so on. Double click to close
and select. Hold the <SHIFT> key to add
to an existing selection.

A=

Inverse Selection To select items that are nots=ldrom a
table. Also known as turning a selection
“inside out”.

NOTE: Navigate to Map > Layer Control to view a layersdextability.

If a layer is selectable, it will respond to the ud the Select tools, the Info tool, and
Label tool. Order of the layers is important. Trder determines which layer will be
selected from. Maplnfo defaults to use the topisekectable layer.

To view the tabular results:

Navigate to Window > New Browse Window and choosk&ion.
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To view the map results:

Navigate to Window > New Map Window and choose Seaje.

To save the results:

Navigate to File > Save Copy As.

To Save the Results from Select Tools:

File > Save Copy As

File > Open (Table)

Static

MapWorld 2008

Page 15 of 20




Getting Started with Maplinfo Professional
Hands On Session 1D

Create a Thematic Map

Create thematic maps to express numeric and catelgta values as colors on the map.
Navigate to Map to Create Thematic Map.
Press the Ranges Type button.
Choose Point Ranges, Five Diverging from the Teteg\ame list.

Press Next.
From the Table drop down choose 1D US CUST.

From the Column drop down choose Order_Amit.
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Press Next.
The Create Thematic Map Step 3 of 3 displays.

Press OK.
Make changes to the thematic map:
Navigate to Map > Modify Thematic Map.
Use the Ranges button to change the number of saargkrange threshold values
Use the Styles button to modify the symbol and icolwices.
Use the Legend button to modify the informationcpthwithin the legend.
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Use the Layout Window

Use the Layout Window to coordinate many MaplInfof@ssional windows (map,
browse, graph, legend, and info tool) on to a airpage that can be printed, plotted, or
save as an raster image that can be placed irdoua@nt or used as an emalil

attachment.
Navigate to Window to New Layout Window.
Choose the option Frames for All Currently Open tiéws.

Press OK.

Use the Select tool from the Main Button Pad, fraiw@n be selected and moved,
resized, and deleted.
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Use the Text tool from the Drawing Button Pad td additional annotation.

Use menu options found underneath the Layout mealign, change number of
pages, and create drop shadows.
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To print the Layout window:
Navigate to File to Print.

To create an image (raster) file of the Layout weivd
Navigate to File to Save Window As.

To save the current session of Maplinfo Professional

Navigate to File to > Save Workspace.
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