Tips and Tricks 1

In this session you will find tips and tricks regarding:

Excel Files

Adding Leading Zeroes

Various MaplInfo Professional Tools
Adding the Current Date to a Layout
Updating Columns

Wildcard Characters

Various SQL Queries

Labels

Thematic Maps

Symbol Settings

® 6 6 6 6 6 6 6 0 o

And many more!

¢ Feel free to share any good gambling tips!



Question:

How do I open an excel document as a native Maplnfo table to allow data editing?

Answer:

Formerly, when comma delimited, Lotus 1-2-3, ASCII, and Excel files were opened in MapInfo

Professional, they were read-only. To edit these files, it would be necessary to have to save a copy
of the file to the native .tab format. There is an option to do this automatically when opening these
types of tables. This should simplify the process of opening and working with files of these types.

1. From the File menu, click Open to display the Open dialog box.

2. Inthe Files of type drop-down list, select Microsoft Excel (*.xls), Delimited ASCII (*.txt),
Lotus 1-2-3 (*.wkl, *.wks, *.wk3, *.wk4), or Comma Delimited CSV (*.csv) to display the
list of available files of these types only.

Loak jn: I&} Exercize_Data j ] i %l

I-_.@.ﬁ.us_':umpanies.xls
S CAN_SITES. xls
E__]LIK_MDI::iIE_TDwers.xIs
E__]LIK_Newsagents.xls
5] Lk _student_list, xls
2 Us_Custamer.xls
s _Sikes. xls

File narne: I j Open I

Files af ype: IMichsu:uft Excel [*.xlz) j Cancel |

Ereferred Wiew: I,.f_-.,ut.;.mati.g j Help |
¥ M aplnio Places IV Create copy in Maplnfo format for readwrite

" Standard Places

&

3. Select a file from the list and select the Create copy in MaplInfo format for read/write
to open it in native (.tab) format.

4. Click Open to open the file.
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Question:
How to add leading zeros to a character field?
Answer:

When a ZIP Code field is imported into MaplInfo as a number, the leading zeros will be
eliminated causing bad results when geocoding. To fix this problem without re-importing,
perform the following steps:

1. 1. Choose Table>Maintenance>Table Structure and seclect the table to modify.
2. 2. Change the type of the ZIP Code column to character. Change the width to 5.

Note:  If ZIP+4, change it to Character with a width of 9.

The table will now look as follows:

HAME ZIP
|:| Rager 123
| rache 23456
| renny BI7E
| Liz 20990
E 599
[ Jen 108

3. Choose Table>Update Column and set up the dialog as follows:

Update Column

Tahble to Update: IZIF'FILE

LCalurin ta Update: IZIF'

Get Walue From T able: IZIF'FILE

Y alue: |Hight$["DDDEIEI“ +ZIF. 5

¥ Browse Fesults

OF. | Cancel | Clear Help

4. Click OK. The results will look as follows:

HAME ze ||
| roger 00123
| rachel 23456
| Penrey 06278
Lz 20990
[ matt a0ga9
[/ ven 00108
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Question:
How can I convert degrees minutes seconds to decimal degrees?
Answer:

To convert columns to decimal degrees we will use the degree converter tool found in our Tool
Manager.

Tool Manager

T ool Loaded Autoload

DBrMS Catalog
DBMS Count Rows in T able

Degree Converter

o

i)

Add Tool...

Edit Toal...

Delete Duplicates

Dizperze Points

Digtance Calculator

E asyloader

GGoogle Earth Connection Uil
Grid Malker

L

Bemove Tool

L e
L o o o o

L

Diezcription:

Thiz program converts a column of data containing DS coordinates OF.

to Decimal Degrees, and Decimal Degrees to
degreez/minutes/seconds. Cancel

Help

Convert DMS to Decimal Degrees (Yersion 1.1) |

Table: |5TATES =l

Get Deg.kinSec walue from: I State Mame j

DS zeparatar I_

Stare results [n: IF'.;.p 1980 J
[ Browse Results

Cancel |

4
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Question:

Is there a way to change the font size, color, or viewable columns in a browser view without
modifying the table structure?

Answer:

Using the Browse>Pick Fields menu option will allow modification of the viewable columns
in a browser view without modifying its structure. Selecting all with Query>Select All and
using the Options>Text Style menu option will allow changes to be made to the color and font
attributes of the browser window. Also, using Browse>Options will provide an option to
remove gridlines.

* Fields in Table
Displays a list of the fields in the current table.
* Add
Add a field to the Browser window.
* Remove
Remove a field from the Browser window.
* Columns in Browser
Displays a list of the columns currently displayed in the Browser window.
« Up
Moves the chosen item in Columns in Browser up one column.
* Down
Moves the chosen item in Columns in Browser down one column.
* Edit Browser Column
Allows a Browser column to be renamed or display an expression as a Browser column.
* Name
Use this box to temporarily rename a Browser column.
* Expression
Use this box to display an expression as a Browser column.
* Assist
This button accesses the Expression dialog box where an expression can be specified.
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Question:
Is there a way I can only show certain columns in a browser every time [ browse my table?
Answer:

A feature in Maplnfo Professional gives you the ability to set a default browser view. For example
if we choose not to see all the columns in the states table we can select our browse menu and pick
fields. This will allow us to select just the fields we choose to view.

Note: There is a check box to Save As Default Browser View.

Pick Fields

]|

Fields in Table: Columnz in Brovezer:

State
FIPS_Code
Pop_15930
Fop_1590
Fop_2000
Murn_Hh_1330

Add x> |
€4 Hemnvel

State
FIPS_Code
Pop_1980
Pop_1530
Fop_2000
MNum_Hh_1330

j Heszet »» |

Mum Hk 1930 =]
lp |

Murm_Hh_1330

Do |

— Edit Browszer Colurnm:

Harme: IState_N ane

Expression: IState_Name

Azsizt.. |

— Options for 5aving Browser Columng

[T Save &z Default Browser Yiew

Cancel

[ ok |

Help
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Question:

What if I want to view derived data within the browser window?

Answer:

We can build an expression to view derived data within the browser window.

Expression E |

Type an expression;

Fop_Female / Pop_15330

Wity |

|£|

I Colurans
Operators

Functions

:

Heb |

Pick Fields

Figldz in Table:

FPop_Cauc_alone_: a
Pop_Asgian_Alane .
Fop_HawiianCPI_g
Fop_Other_Alone_.
Fop_TwolrbdoreR

Columnz in Browser:

Pop_Other_dloned, A
Pop_Cauz_alone_:
Pop_Asgian_dlone_
Pop_HawianOPl_2
Pop_Other_dlone_:
Pop_TwolQrdoreR :
IJRL

— Edit Browser Colurni:

Pct Female

Marme:

E=pression: |Pop_Female / Pop_1330 Bzsist, |

— Options for S aving Browser Columns

[ Save Az Default Browser Yiew

o]

Cancel |

Hep |

0520822
0.473M
0.503951
0.517983
0.493405
0.504827
0.51:3418
0513185
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Question:
How can I update a subset of my table?

Answer:

When a table contains multiple records, and there is a need to update certain records that have
matching criteria, this can be done using SQL.

Here is an example:

EE STORE_TABLE Browser

Store ZIP Color
(1| abc 12180 | red
(]| abe 12180 | blue
|:| x¥Z 12180 | green
(]| abe 12061 | vellow

Assume that you would like to update all stores that are "abc" to their new color of pink.

1. Select the stores from the STORE TABLE using Query>Select.

Select | x| |

a) Stare Besultz in Table; ISeIectiDn \

N b)
Sort Bezultz by Colurmn: I nione j
¥ Browse Fesults [ Find Results In Current bap "Window
k. I Cancel | Save Template | Load Template | Help |
T N |

Type an expression;

Store = "abc” Colurnz E \
Operators Ii C)
d) Functions E

k. I Cancel Werify | Help |

a. Choose the correct table to select from
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b. Click Assist.
c. Choose the correct column from the Columns list.

d. Finish the expression by entering an equals sign, followed by what you are trying to
match, contained in double quotes, as seen above.

2. Click OK twice.

This will open a query of just the specified stores.
Now we will update the color column to be pink.

3. Choose Table > Update Column

Update Column |
T able to Update; IE!uer_l,l'I j
Colurt to Update: IE:::I:::r j

GetValue From Table: quer_u‘l j Join... |
W alue: I"pink" Azzist. . |

v Browse Fesults

] I Cancel Clear | Help |

* Table to Update should be the query, in this case, Query1.

* Column to Update should be the column that contains what we want to update. In this
example, we are choosing Color.

* Get Value From Table will also be the query table.

* Value will be what we want to change it to. If this is being updated with any characters, be
sure to enclose the value in double quotes.

4. Click OK.

Now if we look at the original STORE TABLE, we will see that the values are updated.

E& STORE_TABLE Browser

Store ZIP Color
B 12180 | pink
B 12180 | pink
IR 12180 | green
B 12061 | pink
EE Queryl Browser

Store ZIP Color
B 12180 | pink
B 12180 | pink
B 12061 | pink
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Question:
How do I select using a wildcard?
Answer:

When you don’t know the full string of text you can use a wildcard. For example, you select all
the records that start with a certain letter.

1. Choose Query > SQL Select.

2. The like operator has two wildcards available: the “%” character and the “_” character. The
“%" 1s used for any sequence of characters while the “ ” is for any single character. The
following query will select all States that begin with the letter “M.”

SOL Select Ed |

Select Colurnng: * Tables |£

Columnz |£
Operators Ii

Aggregates |£

Functions |£

[

from T ables: STATES

where Conditior:  |State_Mame Like "ME"

Group by Colurmnz: I

5 Templat
Order by Colurmns: I aave | emplate

into T able Mamed: ISelectiDn Load Template

¢ Browsze Resute [ Find Results In Curent Map Window

k. I Cancel Clear Werify Help

You can also use two wildcard characters in a single condition. For example, if you used
State Name like “%m$” you would get all the States that had the letter ‘m” anywhere in
the name, not just at the beginning.

10

Copyright © 2008 Pitney Bowes Mapinfo Corporation. All rights reserved.



Session 4A: Tips and Tricks 1

Question:

How to select all objects of a certain type? For example, how to select all the line objects in a
table?

Answer:

1. Choose Query>SQL Select.
2. Specify the table name in the From Tables box.
3. Click in the Where Condition box.
a. From the Functions list, choose the STR$() function.
b. Within the parentheses, type in ob .
c. Outside of the parentheses, type the equals sign.
d. In quotes, put the object type to be selected.
For example:

Where Condition: Str$ (obj)="Line"

Tip: Any of the following object types may be used in the query: "Point", "Multipoint", "Line",
"Polyline", "Region", "Collection", "Rectangle", "Rounded Rectangle", "Arc", "Ellipse", or
"Text".

Note: Str$ (obj) will return a null string if there is no object associated with a row. To select
all rows in a table that have no associated map object (e.g., all ungeocoded rows after a
geocoding operation) use the where Condition Str$ (ob7j) ="". However, using the
where Condition not ob7 is another method and is probably faster than a string
comparison to find an empty string.
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Question:

Can a selection be run to find all records in a table that didn't geocode or don't have an object
associated with the record?

Answer:

To find all the records that don't have an object or were not geocoded, use the following SQL
Select statement (Query>Select):

Select |
Select Recaords from T able: ISTDHE_T,.-:-.,BLE j
that 5 atizfy: L obij

at 23T nek o Azsizt. |

Stare Hesults in T able; ISEIectiDn

Sort Results by Colurmn: Inu:une j

¥ Browse Fesults [™ Find Resultz In Current Map *indow
)4 I Caticel | Save Template | Load Template | Help

Substitute the desired table that the selection is to be run on in the Select Records from table
drop down list. The resulting query table will contain only those records without a geographic
object associated with them (i.e., records that didn't geocode).
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Question:

How to select using a wildcard in SQL Select where it is desired to find records with two different
search strings?

Answer:

The following SQL Select dialog box shows how to select all State names that start with "ar" or
"ne" using a wildcard.

SQL Select E2 |

Select Columns: * Tables

Coluninz

2]
2]
Operators | ¥
2]
2]

Agogregates [

from T ables: STATES

Funchions *

where Condition: — |State_Mame Like "ar" or State_Mame Like "nex

Group by Caluring: I

Save Templat
Order by Columns: I 2ave [emplate

inta Table Mamed: ISeIectiDn Load Template

¥ Browse Resut: [ Find Results In Curent Map 'Window

] 4 | Cancel Clear

Help |

Copyright © 2008 Pitney Bowes Mapinfo Corporation. All rights reserved. 13



Question:
How to find records using like, not and the percent sign as a wildcard.
Answer:

In this example, the following records will be used:

EE:SCHOOL_TEST Browser
School_Hame

Albary High Schoaol
Clintan High Schoal
Clinton Community College

Albarry Junoir High School
Clintan Juniar High Schoal

Colonie Junior High Schoal

Troy Junicr High Zchaol
Shaker Junior High Schoal
Saratogs Junior High School

Amzsterdam Junior High Zchool
State University
Syracuze University

Oodododododn

To query the table of schools above for any records having High School in the school name, use
the percent sign (%) as a wildcard in front of the words High School as shown in the SQL dialog
box below. This will return any record with the words High School in it.

B |

Select Colurnns: * Tables |i

Colurnng Ii
Operators |£

Aggregates |i
from T ables: SCHOOL_TEST Funchions Ii

where Condition:  |School_Mame Like "%high school”

Group by Columnz: I

Save Templat
Order by Colurnig: I 2ave [emplate

inta Table Mamed: ISeIectiDn Load Template

¥ Browse Resut: [ Find Results In Cumrent ap Window

k. I Cancel Clear Werify Help
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However, this query also returns all the Junior High Schools.

To refine the query and find only High Schools and not Junior High Schools, use "not" as shown
in the SQL dialog box below.

SQL Select E |

Select Columnsg:

from T ables:

where Canditian:

Group by Colurmnz: I

Order by Colurmns: I

E

Tables |£

Coluriirs |£

Operators |£

Agaregates |£

SCHOOL_TEST

Functions |£

School_Mame Like "Zhigh zchoal' and Schoal_Marme not

like "Zjuriar kigh zchool”

Save Template

inta T able Mamed: ISeIectiDn

¥ Browse Fesults

™ Find RBesults In Cument bap Window

k. I Cancel Clear Werify

Load Template

Help
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Question:

When joining two tables in the Query>SQL Select dialog box, which table should be listed first
in the From Tables section?

Answer:

When joining mappable tables, the map objects associated with the first table listed will
determine the map objects of the resultant query.

For example, if Tablel is made up of points and Table?2 is made up of regions, and Tablel
is listed first, the resultant query will be made up of point objects that satisfied the where
Condition. This will be the case whether it's a geographical join like Tablel .obj within

TableZ2.ob7j, or a columnar join like Tablel.Zipcode = Table2.Zipcode.

If Table?2 is listed first, the resultant query will be made up of regions that satisfied the where
Condition.

The order of columns in the resultant query will be the columns from the first table listed
followed by the columns from the second table listed, if Select Columns is set to the default of
an asterisk (*) which means the query will return all columns from both tables.

If the first table listed is not a mappable table, the map objects of the resultant query will be
determined by the next mappable table listed.

Note: When joining a mappable table to a non-mappable table, only records from the mappable
table are selected. This can cause problems when performing an outer join query to find
records in the non-mappable table. The solution is to make the non-mappable table
mappable via Table>Maintenance>Table Structure and checking the Table is
Mappable check box. Then, a join will select records from both tables, allowing the
ability to perform an invert selection to select all records from the previously non-
mappable table, if it is listed first in the From Tables section.

If neither table is mappable, the order of the tables listed will only affect the order of the columns
in the resultant query.

First Table Listed in
"From Tables"

Second Table Listed in
"From Tables"

Resultant Query Map
Objects

Mappable Table (i.e. Points)

Mappable Table (i.e. Regions)

Map Objects Associated with
First Table (i.e. Points)

Mappable Table (i.e. Regions)

Mappable Table (i.e. Points)

Map Objects Associated with
First Table (i.e. Regions)

Non-Mappable Table Mappable Table Map Objects Associated with
Mappable Table
Non-Mappable Table Non-Mappable Table N/A

16
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Question:
Is it possible to create line objects from a table of coordinates?
Answer:

The following command can be used to convert a table of coordinates to a table of lines. The table
must contain the coordinates for the beginning and the end of the line. It is very important to make
any changes on a copy of the table; it may be necessary to use the original data at a later time.

To execute the command to convert the points to lines or create lines for the table:

1. Open the MapBasic Window through Options>Show MapBasic Window.
2. Type in the following command (all on one line) and press ENTER.

update point table set obj=createline(Start X,
Start Y,End X,End Y)

Caution: Be sure to substitute ‘point_table’ with the name of your table.

Start X, Start Y, End X and End_Y represent the columns in point_table that have the starting
and ending coordinates for each line.

Important Notes:

» Before proceeding with the update, make sure that the table in which the lines will be stored is
mappable. To make the table mappable, make sure the Table Is Mappable box is checked.
(Table>Maintenance>Table Structure)

* Ifalayout window was opened in this session of Maplnfo, re-start MapInfo and then execute
the command before opening another layout window.

* Ifthe table being used is projected, the line objects may not be created properly. To work
around this situation, open up a new map window of a table in a different projection than the
one the table being used in this operation is in. Choose Map>Options and click Projection.
Choose the projection of the table the create lines operation is being used on. Click OK. Then,
execute the MapBasic command and the lines should be created correctly.

Copyright © 2008 Pitney Bowes Mapinfo Corporation. All rights reserved. 17



Question:
How can a clip region be set on more than one map object?
Answer:

The Set Clip Region command isolates a single region of a map such as a State, county or one

defined using a drawing tool for display and/or printing. If multiple regions need to be clipped,
these regions will need to be combined into a single region or a drawing tool will be needed to
trace around the group of regions to be clipped.

A better alternative is to create a buffer around the selected regions with a radius value of zero and
use the resulting buffer object as the clip region.

1. Make the Cosmetic Layer editable through Map>Layer Control.

2. Select the regions to be clipped. (If using the Select tool located from the Main tool bar, hold
the Shift key down while selecting the regions.)

& STATECAP,CITY_125,..,STATES Map Hi=] E3

!
{
N PR ¥

3. Once the regions are selected, choose Objects>Buffer.

4. In the Buffer Objects dialog box, set the Radius value to zero and choose One buffer of
all objects.

5. Click OK.

6. Now choose Map>Set Clip Region. Choose cither to retain or discard the object used for

clipping in the cosmetic layer.

&l STATECAP,CITY_125,..,STATES Map H=] E3

18
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Question:

How can the title of a map window be changed?

Answer:

There is a tool under Tools>Tool Manager called Map Window Manager. Once it is loaded,
go to Tools>Map Window Manager>Set Window Title and enter the new desired title.

Alternatively, type the command below into the MapBasic window and press ENTER:
Set Window FrontWindow () title "My Mapper"

Be sure to substitute "My Mapper" with the desired title.

Question:

How to find the missing Info Tool?

Answer:

If clicking on the map with the Info Tool and the Info Tool window is not appearing, first ensure
that an object (point, polyline or polygon) is being clicked on with this tool. If the Info Tool
window still does not appear, then it is off the screen. The following steps will restore the Info

Tool window.

1. Run Notepad in Windows.
2. Type in the following lines:
'Workspace

'Version 400

set window info show

ln"

set window info position (1.5,2.0) units

3. Choose File>Save. Change the directory to the Maplnfo program directory. Save the file as
INFOTOOL.WOR.
4. Start Maplnfo if it is not already open. Choose File>Open and open INFOTOOL . WOR.

The info tool window will re-appear on the screen.

Also, these two lines can be typed into the MapBasic Window to display the Info Tool window:

set window info show

LU

ln"

set window info position (1.5,2.0) units

19
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Question:
How is zoom layering turned on and off?
Answer:

This is done through Layer Control.

Choose Map>Layer Control.
Select the layer for which the Zoom Layering needs to be set.
Click Display on the right.

In the Display Options dialog box, check the box next to Display within Zoom Range
and enter the minimum and maximum zoom.

5. Click OK.

howbd-=

Objects will only appear when the zoom of the Map Window is between the minimum and
maximum values.

To turn Zoom Layering off, uncheck the box next to Display within Zoom Range in the
Display Options dialog box.

Note: The first check box under Layer Control will display a pink check in the box if the zoom
of the map is outside the range for that layer.

Note: Raster and Grid files may be brought into MapInfo with automatic zoom control. This is
done through Options>Preferences. Then, click Map Window.

W Automatic B aster Zoom Layering
[ Automatic Grid Zoom Layering

20
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Question:
Layer Control shows more layer information using ToolTips.
Answer:

When working with files with long names, being able to see the whole file name is important. The
Layer Control dialog box has increased in size to display longer file names and a ToolTip has
been added to ensure that even longer file names can be read.

Layer Control Ed |

Laver: = é?}- 'IE
Cosmnetic Layer FFFIT
_ M IOV
EanceIJ
STATES
Z:\Program
FilesiMapInfolProfessional\Data) Training_Datal\US\STATES. TAR |
Dizplay... |
Label... |
Thematiz... |
HatLink.... |
Help |
— Lapers Rearder
Add... Eemwel ’V [ | [awr

Question:
What if [ want to merge two maps together into one map window?
Answer:
We can drag two map windows together to merge into one map window using the Drag Map

Window tool on your toolbar. ﬁl
You simply click and drag from one window to the other.

Note: When you merge maps together the merged map will take on the map settings of the
destination map. If you have custom labels it would be in your best interest to check the
map’s projection to make sure it is the same as the destination map’s projection.
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Question:

How do I insert a style into my table?
Answer:

There are two kinds of styles in MapInfo Professional. Global styles are set in the Style
Preferences dialog box and persist every time MapInfo Professional is started. Session styles
are styles created during an edit session and only exist for that session. Session styles apply
regardless of the table being edited. This new feature allows a table-based insert style to be
defined that can be used to add new features to an editable table. The style information is saved as
metadata in the table record and so persists beyond the session.

To insert a table-based style:

1. From the File menu, choose Open and select a map to display.
2. Open the Layer Control dialog box.
3. Make the desired layer editable. This enables the Insert Style button.

Layer Control |
Layer. = £ %
Cozmetic Laper FTIODeE
Diz_boust T T
V¥ F Cancel |
Dowashs I &I
Shabes 20 " 1nsert5t_l,lle...|
arld WM IOV
Dizplay... |
Label... |
Thematiz... |
HatLink.... |
Help |
— Lapers Reorder
Add... Bemove | ’7 Up Drowr

4. Click Insert Style to display the Insert Style dialog box.
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City 125 Insert Style |

*

Ik I Cancel Help

If the layer selected contains a region style, the Symbol Style button displays as in this dialog box.
It may also contain the Line Style button and the Region Style button, depending upon the type of
layer being edited.

Note: Text Styles are currently not supported.

4. Click the button(s) in this dialog box to select the style options you want for this layer.
5. Click OK to save the style options you selected to the table.
6. Click OKin the Layer Control dialog box to display the styles on the current map.

To see this “persistent” quality of the insert style command, close MapInfo Professional. Then
start MapInfo Professional again and display the map again.

Question:
Can I automatically open a thematic of a table?
Answer:

Yes. You first have to create the thematic map, being sure to specify two options in the process.

1. From the Options menu, choose Preferences.
2. Click Map Window.
3. Check the box to Automatically Open Default Theme.

¥ Automatically Open Default Theme

This check box is cleared by default to ensure backwards compatibility.

4. During the creation of the thematic map, you will need to check the Save As Default
Theme View. The default theme information will now be saved to the table’s metadata.

Azzociate Theme YWith T able
v Save Az Default Theme Yiew

[T Femove Default Theme Yiew

This will always open the thematic as the default theme view until you either turn of the
preference in step 3, or choose Remove Default Theme View.

Note: If the table is read-only this option will be disabled.
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Question:

What If I want to copy the information from the statistics window and past it into another
application?

Answer:

Maplnfo Professional enables you to copy the contents of the Statistics and Message windows to
the clipboard. Before MapInfo Professional 8.5, you could not copy anything from these
windows. With this enhancement you can now capture statistical information from your maps and
specially written messages from MapBasic programs, and use that information in other
applications through cut-and-paste operations.

Question:
How can I see the line when I autotrace an object?
Answer:

The autotrace line that traces the nodes of a polyline or polygon is thicker and darker. This should
make the line more visible when you are tracing.

To see this change:

1. Open a Map layer for which you want to trace a polygon or polyline.
2. Make the layer editable.

3. Press the S key to turn on the Snap function and the T key to turn on the Autotrace
functionality.

4. Select the Polygon or Polyline tool from the Drawing toolbar and click at the first node you
want to trace.

5. Move the mouse along the nodes of the line or object you want to trace and you will notice
the line is thicker.

Question:
How can I get a save workspace button on my toolbar?
Answer:
There are three toolbar buttons in MapInfo Professional to simplify opening and saving
workspaces, and saving open windows.
N
* Open Workspace. Click this button to open a workspace. ==
* Save Workspace. Click this button to save a workspace. El

¢ Save Window. Click this button to save the current window.
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Question:
What would cause the Table > Geocode option to be grayed out?
Answer:

If the geocode option is grayed out, make sure that:

a. At least two tables are open; the table to be geocoded and the table being used to geocode
against.

b. The table being used to geocode against (search table) is mappable.

Question:
How do you create a label expression?
Answer:

Often it is desirable to create a label for an object with information that is contained in multiple

columns. The best way to achieve this functionality is to create an expression that defines the
label.

1. Choose Map > Layer Control
2. Click the Label button to bring up the Label Options dialog box.
3. From the Label With list, select Expression. At this point, enter in an expression.

The following examples are based on the CUST browser that is pictured below. Substitute the
names of the columns below for the appropriate names from your data.

EECUST Browser

Hame Amount
[ 1|tz 2,345 0978
1| steve 43932
(]| sue 73429
[ 1| charlie 1,234 567
1| Loi= 95 765
[ 1| chris 3 456 675

* A string constant can be added to a column's contents to clarify the meaning of a label. The
string constant must be contained by quotation marks. A plus sign is used to concatenate the
text objects.

EXPRESSION: "Total Sales: "+Amount

This example will print the words "Total Sales" with a colon and a space, with the value in
the Amount column.

* A multiple line label can be created by adding a carriage return to the expression where the
next line is to begin. The carriage return is represented as CHR$(13) in an expression.

EXPRESSION: Name+chr$ (13) +Amount

This example will print the name value with the amount value directly under it.
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* The two techniques above can be combined to create very descriptive labels.

Question:

EXPRESSION: "Name: "+Name+chr$ (13)+" Sales: "+Amount

This example demonstrates one method of combining concatenations and carriage returns in
an expression.

SAMPLE LABEL:
Name: Liz

Sales: 2348978

Can you set the default Find symbol style to use a specific symbol preference every time?.

Answer:

Yes, you can set a global symbol preference. It is also still possible to set the symbol for a
particular map in the first Find dialog box.

1.
2.

From the Options menu, choose Preferences.
Click Styles to display the Styles Preferences dialog box.

Styles Preferences E |

— Default Object Stules

Fieqgion: |:| Line: ><

Test:

Syrnbal: Aa
SR l Labels:
— Highlight Contral
Line: Region: Multipoint:
Selected Objects: f'\f, Rl .
. i | =
Target Objects: . %4 .

— Default Find Shyle

Symbal; ¥ |
] I Cancel Help

In the Default Find Style area, click the Symbol button to display the Symbol Style dialog
box.

Select the new symbol style using the options in this dialog box and click OK.
Click OK again to close the Preferences dialog box.

26
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To change the Find symbol style locally:

1. Open a map.
2. From the Query menu, choose Find to display the Find dialog box.

Find |
Search T able:

] | Ophons...
for Objects in Colurme; II:it_l,lx j _|:|4|

* indicating the table or column iz indexed

Optional

Befine Search with T able: Innne

[
using Boundary Marme Colurr: Innne j

T

Mark, with Symbal. | [ Eind in Front ‘indow Only

0k, I Cancel Help

Your global symbol choice will be displayed here. This is particularly helpful with busy or very

low contrasting maps.

Note: There are two custom symbols that can be used for the Find functionality. They are the

Find-01 and Find-02 bitmaps. To access these bitmaps, use the Custom Symbols symbol

font.

4O
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Question:
How do I create a table of buffers from my point table?

Answer:

1. From the Table menu, choose Buffer.
2. Choose the table for which you wish to create the buffers and store the results in a new table.

Table Buffer

Buffer objects fram table:

Store rezults in table: I e j

Mest » | Caricel | Help |

3. Set the field properties and save the new table. When this is complete you can now set the

properties of the buffer.
e N > |
— Radius
& Yalle
" Fram Calumn INumeriu:_u:u:ude j

Units: I milez ~ I
Smoothness: I'I 2 zegments per circle

¥ Orne buifer of all ohjects

" Ore bulfer for each object

— Buffer \Width Diztance using:
* Spherical

€ Cartesian

| k. I Cancel Help
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Question:

Is it possible to return a count of how many points are in a polygon? For example, using a table of
customers by ZIP Code, how can a count be returned of how many customers are within each ZIP
Code?

Answer:

Select Query > SQL Select and fill in the dialog box as shown below. DC_ZIPS is a table of
ZIP Code polygons and DC_BCUST is a table of customer points.

SQL select | x| |

Select Columns: DC_ZIPS ZIP_Code, Count[*] Tables |£

Coluninz |£
Operataors Ii

Aggregates |£

Functions Ii

fram T ables: De_beust, DE_ZIPS

where Condition:  |D'c_beust. Oby Within DC_ZIPS.0bj

Group by Colurmnz; IDI:_EIF'S.EIF'_I:DI:IE

Save Templat
Order by Colurnig: I 2ave [emplate

inta Table Mamed: ISeIectiDn Load Template
¥ Browse Resut: [ Find Results In Cumrent ap Window

k. | Cancel Clear

Help |

This query will return two columns; the ZIP Code and the count of the number of customers in

each.
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Question:

How do you create a thematic map using two columns at the same time? (This is known as a
bivariate thematic map.)

Answer:

A bivariate thematic map uses point or line objects to represent two variables. For instance, a
colored circle could represent a particular company while the size of the circle would represent
the number of orders for that company. There are, however, limitations to this type of thematic

mapping:

* At least one of the maps must be based on a numeric variable.
* There is a limit to using 2 ranged or 1 ranged and 1 individual variables.

In the following example, the CriminalActivity table will be shaded by type of crime as
well as the time the crime occurred.

First, create the Individual thematic map for the types of crimes:

1. Choose Map > Create Thematic Map.

2. Inthe Create Thematic Map - Step 1 of 3 dialog box, choose Individual as the type and
Point IndValue Default as the template and click Next.

3. Inthe Create Thematic Map - Step 2 of 3 dialog box, choose the
CriminalActivity table and choose the Type column. Click Next.

4. Inthe Create Thematic Map - Step 3 of 3 dialog box, click OK.

Second, create the ranged thematic map based on the time the crime occurred.

1. Choose Map > Create Thematic Map.

2. Inthe Create Thematic Map - Step 1 of 3 dialog box, choose Ranges as the type and
Point Ranges, Varying Size as the template. Click Next.

3. Inthe Create Thematic Map - Step 2 of 3 dialog box, choose the
CriminalActivity table and choose the Crime Time column. Click Next.

4. Inthe Create Thematic Map - Step 3 of 3 dialog box, click Styles.
In the Customize Range Styles dialog box, click Options.
6. Inthe Apply area, choose Size.

0
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Customize Range Styles |
— Auto Spread
£ Color {* Size  None
— Styles —&uto Spread Stle by——
% Sguare Foot
F2BE AM ta11:34:11 P
ra ° " Constant
i Click on Style Buttons " Lag
at left ba change styles
O = | flection
— Irflection at: Inu:une TI
O Style for "4l Others" : |
—— Range: Sl
] | cAppl
T Al Attibutes
@ € Color
— 12:01:32 Ak bo 12:44:56 Ak 0 Size

¥ Replace Layer Style << Options |
| k. I Cancel | Help |

7. Click OK.

Tip: You may wish to adjust the ranges of time in Step 3 before proceeding. You can do this by
clicking Ranges.

Click OK in the Create Thematic Map - Step 3 of 3 dialog box. The resulting bivariate
thematic map displays the type of crime by color and the time range by the size of the circle:

&8 CriminalActivity Map B ]

s

CrirminalActivity by Type ﬂ
@ Burglary (75)
& Criminal Damage (94
@ Crugs (10
@ Fraud or Forgery &
O Cther Motifisble Offences (5
& Robbery (33
@ Sexual Offences (M)
@ Thett and Handling (155)

@ Violence Against the Person (116)
CriminalActivity by Crime_Time

O 32616 At 11:34:11 PM (103

(] 230:58 AMto 32816 &M (109)

() 12852 Abto 230:56 &M (110)
) 12:44:58 AMta 12552 AWM (1100

0 1201:32 AMto 12:44:56 M (110) —
2

£ Al
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Question:

How can a region table be shaded based on the number of point objects falling within each

region?
Answer:

Start with a region table (e.g., States) and a point table (e.g., City 125).

1. Choose Map > Create Thematic Map and select Ranges and a region range template
2. Inthe Create Thematic Map - Step 2 of 3, sclect the region table and from the Field list,

choose Join.
Create Thematic Map - Step 2 of 3 | x| |

Select a Table and a Figld:

T able: I Shates

[
Field: |Pap_1380 =l

i AzianH awiiandlone_2000

M Pop Black_2000
Fop_Other_AlonetndTwoR aces_2000
Fop_Cauc_alone_2000
“|Pop_dsian_alone_2000
Pop_HawiianOP|_Alane_2000 =
Fop_Other_alone_2000

Pop TwalrkareRaces 2000
E mpression... i

3. From the Get Value From Table list, choose the point table, and from the Calculate list,
choose Count.

Update Column for Thematic |

T able to Update: States

Colurt to Update: Add Mew Tempaorary Colurmn

GetWalue From T able: II:it_|,|_1 25 j Jair... |
Cacuiae [T

] I Cancel Clear Help

4. Click Join.
5. Use the second option, and select where the object from the point table is within the object
from the region table.

32
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Specify Join |
Jain
" where IState j from table States
matzhes IState j from table Citp_125

{* where object from table City_125

IW "I object from table States
k. I Cancel Help |

6. Click OK and OK to return to the Step 2 of 3 dialog box.

7. Check Ignore Zeroes or Blanks to prevent counts of zero (i.e., region objects with no points
within them.

8. Click Next.
9. Make any necessary changes in Step 3 of 3 and click OK.

Question:
Can I the items in an Individual Value thematic legend in a custom order?
Answer:

There is a feature that allows the sort order to be changed in the legend list for Individual Value
thematic maps.

Note: This feature is only available for Individual Value thematic legends.
To customize the legend label order of an Individual Value thematic legend:

1. Create or modify an Individual Value thematic map using the Thematic dialog boxes.

2. Inthe Modify Thematic Map dialog box or the Create Thematic Map - Step 3 of 3
dialog box, select the Custom option in the Legend Label Order area.
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Modify Thematic Map | x| |

Preview: — Customize
CriminalActivity by Type Settings... |
@ Burdlary (7
& Criminal Damage J Styles... |
& Drugs (1
@ Fraud or Forgery (1 ﬂl
O Other Motifisble Offences
3 Robbery (3
& Sexusl Offences
& Thett and Handling (19

# “iolence Against the Person (11

Murnber of Calurnts: I‘I :I _?W?Chtssl?e
* Font Size

— Legend Label Order—————————— = Small

" pscendng  © Descending " Large

Order... |

— Template

—Azzociate Theme With T able
[T Save Az Default Theme Yiew

[~ Remaove Default Theme Wiew Merge...
] I Cancel | Help

3. Click Order to display the Customize Legend Label Order dialog box.

Save bz

1

Customize Legend Label Order |

Burglary

Criminal Damage

Drugs

Fraud or Forgery

Dkher Motifiable Offences
Robbery

Sexual Offences

Theft and Handling Move g
Violence Against the Person
all others

d

[Move Dawn

Ok, I Zancel Help

4. Select an entry in the list to move and use the Move Up or Move Down buttons to place it
in the desired order.

5. Click OK to save this order.
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6. Click OK again to display the new thematic map and the new legend.

Important Notes for Creating and Merging Theme Templates:

* Maplnfo Professional saves the custom label order only when the option to Save Individual
Value Categories is selected in the Save Theme to a Template dialog box. This implies that
when creating a theme based on a template, MapInfo Professional applies the custom label
order only when the thematic expression creates the same categories as those in the template.

*  When merging theme templates, the custom label order from the source template is applied to
the current theme only when the option to Merge Individual Categories is selected in the
Merge a Template to a Theme dialog box and the template and current theme have the same
number of categories.

Question:
Is it possible to create a layout window that when accessed, will display the current date?
Answer:

The procedure for this will involve creating a workspace template that consists of a blank layout
with a date stamp. Once the workspace is created, it can then be used to set up maps for printing
in other workspaces.

Choose Window > New Layout Window.

Choose File > Page Setup to set the desired page size and orientation.
Choose File > New Table.

In the New Table dialog box, select Open New Mapper. Click Create.

In the New Table dialog box, simply add a field called ID. The contents of the table are not
important in this case. Click the Create.

aprowbd-=

6. When prompted to save the table, select a directory, and assign a name to the table like
Date Stamp.

7. Once the new Map Window appears, the Date Stamp layer should already be editable.

The next step involves creating a point object with no style that can be labeled with an expression
that uses the MapBasic CurDate() function.

8. Choose Options > Symbol Style. In the Symbol Style dialog, make the symbol type N
for None:
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Symbol Style |

—Sample

Fort  |Mapinfo 3.0 Compatible | |12 <]

Sumbal: | Mone I i
Color: | I, |

Botation dngle: I deg,

B ackaraund Effests
™ Hone ™ Drop Shadaw

= Halo [~ Eold
= Eorder

| ] I Cancel | Help |

9. Once the symbol style has been set to None, use the Symbol tool ll and click inside the
blank Map Window.

10. After clicking inside the Map Window, save the Date Stamp table (File > Save Table).

11. Choose Map > Layer Control. Place a check in the Autolabel box and then click the
Label:

Layer Control |
Layer: = & %
||:|:|smeti|: Layer FTIODeE ] |
M Cancel |
Ingert St_l,lle...l
Dizplay... |
Thematiz... |
HatLink... |
Help |
— Layerz Reorder
Add... Eemwel ’V 0] | [ mwr
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12. In the Label Options dialog box, choose Expression from the Label With list.
13. Select or type in the CurDate () function.

Expression E |

Type an expression;

CurD ate(] Columnz |i
Operators |£
Functions |i

| ()% I Cancel W erify | Help |

14. Click OK.
15. In the Label Options dialog box, select the desired font size and style.
16. Click OK.

Now the date appears in the Map Window:

& Date_Stamp Map [_ O]

0ar0/2008

The Map Window can be added to the blank layout as a frame.

17. Using the Frame tool El, draw a frame on the layout in the desired location for the date to
appear.

18. When the Frame Object dialog box displays, make sure the window being added is the
Date Stamp Map.
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Frame Object |

Bounds =1: IE.EI2E|EI in 1 IEI.'IEISE in
Bounds #2: I.'-".'ISEE in T |1EI.'I153 in

LCenter #: IE.DBSE in e IEI.EEIEIEI in
width: |2.1EI? in Height: |1.IZI12 in

Map Scale Optione——————————————
Scale: 1in= |1 118 i ¥ Fill Frame with Cortents

% Change Map Zoom
" Besize Frame

| k. I Cancel | Help

19. Click OK.

20. Lastly, choose File > Save Workspace. For easy distribution, save the workspace file in
the same directory as the Date Stamp table.

Now every time the workspace is opened, the layout will appear with the current date.
Question:

Changing the number of columns or rows in a cartographic legend frame.
Answer:

It is possible to change the number of columns or rows in a frame legend to control the legend
frame display.

1. Create a map and legend using Map > Create Legend with several variables.

IE Legend of Dc_bcust,City_125,Dc... =]
Y

Dc_beust Legend

v Foint
City_125 Legend
* Pairt

Dewashs Legend

Line

states Legend

Fegion

Wworld Legend

Fegion

o o
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2. Once the legend is created, right click inside the legend and choose Refresh.

Refresh Legend E2 |

v Ef!efresh ﬁt_l,lles:f ¥ Fefresh Alignment Ok

¥ Refresh Layout Cancel
MHumber of columns:

= Potrait |5 j

Mumber of raws:; Help

™ Landscape IE j

[ Refresh Style Sample Size
= Smal
i [age

bl

3. Enter the number of columns (from 1 to the number of items in the frame) for this frame and
click OK.

IE Legend of Dc_bcust,City_125,Dcwashs,...,World Map

Dc_beust Legend  City_125 Legend Dowashs Legend  States Legend World Legend —

v ot * Pt =———tine [ JRegon [ Region
-
4 | :

Question:

Is there a MapBasic program that will automatically update columns with X and Y coordinates in
a table’s native projection?

Answer:

The Coordinate Extractor will add two columns to a selected table and update the columns with X
and Y coordinate values in the table’s native projection as opposed to the default projection of
Longitude/Latitude.

For example, if a table is in UTM Zone 16, the coordinates will be in UTM values. If a table is in
the default Longitude/Latitude projection, the coordinates will be in decimal degrees.

For objects other than points (such as polygons, lines), the X and Y coordinates will represent the
location of the centroid of the object.

To run the program:

1. From the Tools menu, choose Tool Manager.
2. Load the Coordinate Extractor tool.
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Tool Manager

DBrMS Catalog
DBMS Count Bows in Table
Deqree Converter

Toolz Loaded Autoload
Autalabeler |= M Add Taal...
Concentric Ring Buffers ¥ +
Cornect the Dots [ r Edit Toal...
Coordinate Estractor v
Coord5ys Bounds Manager r Remove Tool
Create Line By Length r
—
—
—

i o o o o

il

Diezcription:

=
e

T hiz utility adds bwo columnz bo an open table and updates each
column with = and %’ coordinates in the table's native projection. c |
ance

Help

3. From the Tools menu, point to Coordinate Extractor and choose Extract

Coordinates.
Coordinate Extractor {Yersion 2.4} Ed |
Table name:
& columi; - -
[Lemgitude E asting...] I.-i‘-.manH awiiandlone_2000 j
" coolurmit: -
[Latitude Morthing..) | Temitory_Name =]

Create new columnz to haold coordinates. . |

Coordinates will be extracted in the following projection:
Longitude & Latitude [MAD 27 for Continental LIS]

£+ Use Table's Mative Projection

£ Use Non-Mative Projection Select Projection |

¥ Browse Results

(] I Cancel |

4. You can choose the table from which to extract the coordinates.

5. You will also need to specify the columns to hold the extracted coordinates, but if you don’t
have any empty columns, you can add them using the Create new columns button.

6. Click OK when complete.
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Question:
How to find the closest or furthest point(s) from another set of points.
Answer:

The Distance Calculator tool calculates the distance between all the objects in a table or two
tables. It then returns the closest or furthest object(s) and populates a browser window with
results. For example, you could calculate the distance between students and the schools that they
attend.

This can be done in MaplInfo Professional by using the Distance Calculator tool.

From the Tools menu, choose Tool Manager.

Load the Distance Calculator tool.

From Tools menu, point to Distance Calculator and choose Run Distance Calculator.
4. You can choose the origin and destination tables, and specify any search criteria.

W=

== W -
Select a map window to view. 5(% [ L2 = Y l 2] Select a table to calculate the
[Dc_stdnt,De_schl,...DC_ZIPS M x| | o] N = Neilll et (it (O
L | I Di_schl ﬂ
- I = i
Layer Contrel | i L1 Select an identifying column for
__ﬁ anwA R ﬁ r ™ = " the objects fram the origin table.
L | ’A b I ISchooI_Name j
SELECT =10 & — £
= M
MARGLIEE SELECT b ;||||; r Select a table to calculate the
digtance to.[Destination)
POLYGOM SELECT p T 0l
BOUMDARY SELECT X ~
Select a column to identify
URSFELEET UL ] the destination objects.
g5
Z00M I Z00M oUT T ILname ﬂ
Pah SNaP 7 T
Kl [; r
Origin |Des1i|1ati0|l |Distance_Re3uIt IDl;I  SET CRITERIA FOR DESTINATION
¥ lgnare distances of 0. ' Find the clogest point
. o ™ Find the farthest point,
I Use the following criteria,
[ 2 |
NP &
[ = =
Enter the number of distances to find. I1
Select the unitz ta dizplay distance. Imi|33 'l

-

] » Clear Results | Save Results | Zalculate Distancei Exit |

5. When you click Calculate Distance, the results will be displayed in a mini-browser in the
bottom left-hand corner. You can save the results from here if needed.
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Question:
How would the spider graph tool be used?
Answer:

The Spider Graph tool draws lines between objects in a single table, or the objects from two tables
based on a join. It then creates a new table of lines that connect the objects from the origin table to
the destination table based on matching column values. By default, the lines are color-coded
based on their table of origin. Also by default, the new table includes a distance column that
stores the length of each line.

To use the Spider Graph tool:

1. Use the Tool Manager to load the Spider Graph tool.

2. With the appropriate tables open, from the Tools menu, point to Spider Graph and choose
Spider Graph.

Note: The Spider Graph tool works with mappable vector tables only. It can not be used with
raster images.

3. In the Spider Graph dialog box, select the origin table, then select the column that will be
used to join the origin table to the destination table

4. Select the destination table, then select the column name that will be used to join the
destination table to the origin table.

5. Select the columns to include in the resulting table. To select multiple columns, hold down
the CTRL key while you click. If no columns are chosen, Spider Graph will automatically
include the join column specified for the origin table.

6. By default, the Spider Graph tool will color-code the resulting lines and add a distance
column to the new table to record the length of each line. If it is not desired to have these
features, clear the appropriate checkbox.

7. The distance lines will use units of miles by default. To change this, select another distance
unit from the UNITS: drop-down list.

Spider Graph E3

Choose vour Ongin T able: Chooze ¥our Destination T able: Select the colurmne to include in the
rezulting table.
IDc:_schI j IDc:_stu:Int j
De_schl.Schoal_Mame -
Select a calumn from the arigin Select a calumn fram the destination Dc_schl.Type
table ta baze the jain on. table ta baze the jain on. Dc_gchl.Enrollment
- De_ztdnt Lname
School Mame Lname Dc_stdnt.Friame
Type Fhame Dc_stdnt. Schaol
Enrallment  School [ [ R,
":"-!j'j'ESS Di_stdnt. Ciby -
Ell_'rl e <tdnt Fin cads J
Zip_code
Telephone Units: Imiles j
v Color code results
v Add line distance
ob. | cocel_|
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8. C(lick Create Lines.

9. Enter a new name and location for the resulting table in the Save Copy As dialog box and
click Save.

L
Il

AL

g
[]
[

Question:
How can I delete duplicate records in a table?
Answer:

There is a tool in MapInfo Professional called Delete Duplicates that allows you to delete
duplicate records from a table while retaining map objects. This tool does not change the original
table in any way. Keep in mind that MapInfo Professional has a 255 byte/ 5-column limit for a
Group By clause, so it may be necessary to change the size of the columns if they are unusually
wide.

When referring to duplicate rows, this mean rows that have duplicate occurrences of the same
column value for the column that was selected.

To remove duplicate records from a table and save the cleaned table to a new file:

1. Use Tool Manager to load the Delete Duplicates tool.
2. Open the necessary table or tables.

3. From the Tools menu, point to Delete Duplicates and choose Delete Duplicates to
display the Delete Duplicate Records dialog box.

Delete Duplicate Records E3
Select & Table Select Colurmins

Mame
USPS_Mame
State

Area
Fopulation
Hhld_Units

[ Count Cancel |
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4. Select the table from which to delete duplicates in the first list. A list of the columns in that
table displays on the right.

5. Select the column that contains information that should be unique to each row from the
Select Columns list. It is possible to select multiple columns to group by, but keep in mind
Maplnfo has a 254-byte (or in this case character) limit on any group by statement. Delete
Duplicates will display an alert if this limitation has been exceeded.

Caution: The Delete Duplicates tool does not modify the original table. However, to avoid
deleting data incorrectly, give this step a lot of thought. For example, it is not
recommended to select customer names or addresses for this step.

6. Select the Count checkbox to add a column to the new table that shows the number of
instances of the column value found in the original table.

7. Click OK. The Please Choose a Path dialog box displays.
8. Select a path and a filename for the new table in this dialog box. Click save.

The tool removes rows containing duplicate column values according to the column that was
selected. A browser window displays with the results of the new table.

E& no_dupes Browser [_ | O

Lname Fname School Address
|:| Cohn Stephen Ramapo High Zchoal 1025 WERMORNT
|:| Taffle Becky St Albertus Magnus 1850 M ST MY
|:| Wiesson Christing Spring Yalley High Schoo | 1915 14TH ST N
| Ty=on hiitch 15001 ST My 54
|:| Blackman Patricia Cohoes High School 1920 L ST b

Note: If you checked the Count box, the last column of the table contains the count of instances
of the row containing duplicate column values in the original table.
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Question:
How can I synchronize my Map Windows?
Answer:

The Synchronize Windows tool provides toolbar icons that allow the ability to automatically
share changes made in one mapper window to all other mapper windows in a given Maplnfo
Professional session. For example, use this tool to look simultaneously at several sets of complex
feature data covering the same location. In cases where a single map containing all the data would
be more confusing than helpful, several synchronized maps can often display the information
more clearly. The ability to embed thematic legends is useful to provide greater understanding of
the data being presented. The icons on the Sync Windows toolbar are shortcuts to commonly used
functionality.

1. Use Tool Manager to load the Sync Windows tool.

w80 e |n/m|e|x

From left to right, these buttons are:

a. CLONE MAP WINDOW - Provides the same functionality as MAP>CLONE VIEW.

b. RENAME CURRENT MAP WINDOW - Allows the currently active Map window to be
renamed.

c. TILE WINDOWS - Provides the same functionality as WINDOW>TILE WINDOWS.

d. SYNC ALL MAP WINDOWS - Provides a way to synchronize multiple map windows
and embed thematic legends.

Synchronize Map Windows | x| |

[~ tlways Synchronize Map Windows

Synchronize All kap Windows Mow |

Synchronize Windaws Options
¥ Synchronize bap Center

¥ Sunchronize tap Zoom

[ Ahways Embed Thematic Legend i the Map Window
Embed &ll Thematic Legends Mow |

Ermbted Thematic Leaend faor the Cument WWindaw |

Remove All Embedded Thematic Legends |

Eemove Emtedded Thematic Legend farn the Current Windaw |

Note: Note: It is possible to synchronize the maps by center or zoom level.
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e. CREATE A SYMBOL ON ALL COSMETIC LAYERS - Provides a way to draw a
symbol in the same location across multiple map windows.

f. CREATE A POLYLINE ON ALL COSMETIC LAYERS - Provides a way to draw a
polyline in the same location across multiple map windows

dg. CREATE A RECTANGLE ON ALL COSMETIC LAYERS - Provides a way to draw a
rectangle in the same location across multiple map windows.

h. CREATE A ELLIPSE ON ALL COSMETIC LAYERS - Provides a way to draw a ellipse
in the same location across multiple map windows.

i. CLEAR COSMETIC LAYERS - Clears the Cosmetic layers of all of all synchronized

mapper windows.

Caution: This removes all features added to the Cosmetic layers, not just the 'synchronized'
features added by this tool during this session.

Question:

Can I search and replace to update Multiple Columns?

Answer:

The Search and Replace Tool in MapInfo Professional can replace multiple column entries in a
selected table. This tool is particularly useful when names change or specific character data
changes. To search a table, the file must be open.

To use the search and replace tool:

1. Use Tool Manager to load the Search and Replace tool.

Open the necessary table for which it is desired to search and replace data. MapInfo
Professional must be able to read the tables to search.

3. From the Tools menu, point to Search and Replace and choose Search and Replace.

Table To Search Il:lc_zips j
Column To Search ZIP_Code

I ame

USPS_Mame

State

Search String
Replacement String

[ Case Sensitive

Cancel | (] I

Note: The Column to Search list allows for picking multiple columns.

© N O~

Select the table and columns to search from the lists.

In the Search String box, type the text to find.

In the Replacement String box, type the text you wish to replace it with.

If the string entered should be case sensitive, select the Case Sensitive check box.
Click OK to begin the search and replace process.
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Question:

How is it possible to move a workspace to another location?
Answer:

Use the Workspace Packager tool.

Use this tool to create a copy of a workspace in a new location or folder. It will copy all the data
referenced by the workspace to the same location. MapInfo Professional updates the internal
references in the workspace file to point only to the "packaged" copies of the data so the new
workspace can be opened no matter where the folder is moved or copied, even if the folder is
moved or copied to a different computer.

1. Use Tool Manager to load the Workspace Packager.
2. From the Tools menu, choose Workspace Packager. There are two options:

a. Package Current Workspace will allow the workspace that is currently open to be
packaged.
b. Select Workspace to Package will allow the workspace(s) to be chosen to package.

To package your current workspace:

1. Itis a good idea to make a new folder in which to place the packaged workspace and
corresponding files. Choose the new folder that was made by clicking Browse.

2. Use either the original files (good when sharing a workspace that is already on a shared
resource) or make a copy (good to send to someone else).

3. It is possible to customize the copy type if desired (for advanced users).

Workspace Packager

E=port current M aplnfo desktop to: Browse... |

Z:4Documents and SettingziMy DocumentzhPackaged. \w0R

Tables stored localy: IMake hative copy [Save Copy &) j

Tiables witt LINL pattis: IMake hative copy [ ave Copy &) j

Bemate and linked tables: IMakE native copy [Save Copy A j

[ Customize copy type for each table Sdvanced Copy Dptions... |
ok LCancel Help

If you had chosen Select Workspace to Package, you would be prompted with a dialog box,
allowing you to select multiple workspaces.
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Question:

When opening a workspace, an error is received "Variable or field not defined". How can this be
fixed?

Answer:

This error message is generated when trying to open a workspace in MapInfo Professional. This

usually happens when a variable or field in a table that is being referenced in this workspace has
been altered outside of the workspace. For example, a column name in a table called "streets" was
renamed to "address".

There is a tool called Workspace Resolver that allows opening a workspace that references tables
that no longer exist in the location specified by the workspace file. This tool can perform a search
and replace the missing table or alternatively resolve the workspace file by ignoring the missing
table.

Using the Workspace Resolver to remove references to a missing table in a workspace:

1. Use the Tool Manager to load the Workspace Resolver.

2. Close all of the open .tab files before using the Workspace Resolver. If the tables aren't
closed, a prompt displays asking if the application should close them. Click Close All to
continue.

3. From the Tools menu, point to Workspace Resolver and Resolve Workspace
Tables. The Workspace Resolver dialog box displays.

Specify the workspace to be resolved in the Source File box.

o

Maplnfo Professional pre-fills the Destination File field with the same name and path plus
the word Resolved as a convenience, but this file can be renamed as necessary.

6. Inthe Mode area, choose Automatic or Interactive.
* Automatic will delete any references to missing tables.
* Interactive will prompt you to find the missing tables.

7. To save the workspace after the references are removed, select Save Workspace. This
must be selected or the workspace is not saved.

®

To open the new workspace file after the references are removed, select Open Workspace.
To display the results of the process, select Generate Report.

©
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Workspace Resolver ¥1.0 | x|

Source File:
IE: SProgram Filez\M aplnfohProfeszionalhD atah T raining_Databwork spaceshUS_Finding \wOR

Destination File:
IE:HF'ru:ugram Filez\Maplnfo\Professional\Datah Training_Data'workzpaceshUS_Finding_Resoly J

kMode:
" Autematic - Feferences ta any table not found are deleted.

% |mteractive - If a table iz not found prompt to locate table,

[ Usze search directories v Open‘waorkspace Ok
™| Use first table found ¥ Save\Workspace
™| Eromptif multiple found ¥ Generate Report Cancel |

10. Click OK to begin the process.

Note: The resolved workspace has not been saved if the Save Workspace checkbox has not
been checked.

Specifying Directories to Search

A list of directories can be created for the Workspace Resolver to search to find the missing

workspace .tab files.

To create a list of directories for the Workspace Resolver tool to search for missing workspace

.tab files:

1. From the Tools menu, point to Workspace Resolver and choose Settings. The
Directories to Search dialog box displays.

Directories to Search E3

Directony: C:"\Pragram Files\M aplnfa\Pral ynalI0 T cols J

Add To List | Bemaove From List |

C:\Program Filez\M aplnfotProfessional 30T oolsh

2. Use the Directory box to find the first directory the Workspace Resolver should search.

3. Click Add to List. Repeat this process for as many directories as desired to add to the list.
The Workspace Resolver searches the subdirectories of any folder selected.

Note: If a directory is entered by mistake or it should be removed, highlight it in the list and
click Remove from List to delete it.

4. When this list has been completed, click OK to save the list. The Workspace Resolver uses
this list when searching for missing .tab files.
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Question:

How can I save my map, layout, browser, 3D window, redistrict window or graph as an image?

Answer:

By using the Save Window as functionality.

1. Open a window to save in the new format.

2. From the File menu, choose Save Window As to display the Save Window To File
dialog box.

Save Window ko File Ed

Save IBM_I,I Documents j = |=_°F "

Tables Directary

File name: ILlntitIeu:I.I:ump j Save

Save as lype: I"-.-k-"inu:lu:uws Bitmap [*.bmp j Cancel

il

wirif] Help

Windows Enhanced Metafile [*.emf]

* Maplnfo Places JPEG File Interchange Format [*.jpg)
JPEG 2000 (" p2)

¢ Standard Places Portable Metvark Graphics Format [*.phg)
GeaTIFF [*.hf]
Tagged Image File Farmat [ k]
TIFF ChAE, [*.tif]
TIFF CCITT Group 4 [*tf)
TIFF L2 [ kif]
Graphic Interchange Format [, gif]
Phatazhop 3.0 [*.pad]

3. From the Save As Type list, choose the desired file format.
4. Specify a file name and click Save. The second dialog box opens.

50
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O No o

Question:

Save Window As |

—Image Size
£+ Same az Window
" Custom Size

widh: [5.55 " EE
Height: |2.3E; in |22? pirels
Rezolution: IE'E dpi

[ Create a Geographically Feferenced Tab File
[ Usze Antigliasing

Save I Cancel Advanced... Help

pixels

Specify the size of the image, if necessary.

Adjust the resolution by changing the dpi (dots per inch) if necessary.
Use antialiasing (smoothing) if necessary.

Click Save.

How do I save a map window as a geographically referenced Tab File?

Answer:

You can now save the current Map window and automatically register it by creating a .TAB file.

To save the current map as a .TAB file:

1

2.
3.
4

1. From the File menu, choose Save Window As.

Select the type the file name and click Save. The second dialog box displays.
Select Create a Geographically Referenced Tab File.

Click Save.

Maplnfo Professional automatically creates registration points based on the current map view and
saves it as a .TAB file. When you choose File > Recent Files, the file you created is the first file
in the list.

Note: If Maplnfo Professional cannot create registration points for the window image, an error

message displays. This might happen if you pan outside the bounds of the map.
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Question:
Is there a list of the Function Keys and Shortcuts?
Answer:

Function Keys:

F1 —Help F4 - New Graph Window
F2 - Browse Table F5 - New Layout Window
F3 - New Map Window F7 - Get Info

F8 - Text Style
F9 - Create Thematic Map
F10 - Create Prism Map

Menu Shortcuts:

File menu: Options menu:
New Table Ctrl+N Line Style Shift+F8
Open Table Ctri+O Region Style Ctrl+F8
Save Table Ctrl+8 Object Style Alt+F8
Save Workspace Ctri+K Text Style F8
Print Ctrl+P
Exit Alt+F4
Edit menu: Map menu:
Cut Ctrl+X Layer Control Ctrl+L
Copy Ctrl+C Create 3D Map F11
Paste Crtl+V Create Prism Map F10
Clear Del Create Thematic Map F9
Reshape Ctrl+R Modify Thematic Map Alt+F9
New Row Ctri+E Previous View Alt+LeftArrow
Get Info F7
Tools menu: Window menu:
Run MapBasic Program Ctrl+U New Browser Widow F2
New Map Window F3
Objects menu: New Graph Window F4
Set Target Ctrl+T New Layout Window F5
Clear Target Ctrl+Del Redraw Window Ctrl+D
Tile Windows Shift+F4

Query menu: Cascade Windows Shift+F5
Find Ctri+F
Unselect All Ctrl+W
Find Selection

In Current Map Window Ctri+G

In All Windows CtrlI+A
Table Menu:
WFS Table refresh Alt+F5

MaplInfo HotKeys:
* Snap-S

e AutoNode - N
¢ (Crosshair - C
e Autotrace - T
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Useful URLS

Maplnfo Home Page
http://www.mapinfo.com/

Maplnfo Knowledge Base
http://testdrive.mapinfo.com/kbase_by product

Maplinfo BugBase
http://testdrive.mapinfo.com/kbase_by_product

Maplnfo Product Documentation
http://extranet.mapinfo.com/support/documentation/manuals.cfm

Maplnfo Training
http://www.mapinfo.com/training

DirectionsMag -(not maintained by MaplInfo)
http://www.directionsmag.com/files/

Maplnfo FAQ -(not maintained by Maplnfo)
http://www.integrated-mapping.com/scripts/mi_fag/fag.dll/Index

Maplnfo-L - (not maintained by Maplnfo)
http://nt1.directionsmag.com/mapinfo-I/
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